[Xprint] Xprint and LTSP

Thomas Dodd ted at cypress.com
Wed Jan 21 12:56:45 EST 2004


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



Richard Duran wrote:
| Does anyone one this list have any experience with LTSP? We've
| configured our clients to run Mozilla locally, and I've set XPSERVERLIST
| to <server>:33 hoping that's all I needed to do. I know Xprint is
| running because when I run "xplsprinters" on the server, I get a list of
| CUPS printers set up on the server.
|
| I'm not sure how to test connectivity from the LTSP client to the Xprint
| server. When I try printing from Mozilla, I'm hoping to see the same
| list of printers, but all I get is PostScript/default.

Is XPSERVERLIST set before mozilla starts?
Try setting XPSERVERLIST and starting mozilla from a terminal window.

If you just login through X(GK)DM and run mozilla from a menu, then
XPSERVERLIST is probably not set. Also, are you using a build of mozilla
with xprint enabled. The default RedHat/Fedora builds don't.

| I've tried making "xplsprinters" available to the client, but that only
| gives me the following message:
|
|   no printers found for printer spec ""
|
| Is there a command line tool that only requires XPSERVERLIST to be
| defined in order to run on a client? Do I need to make "lpc" available
| to the client?

xplsprinters only needs XPSERVERLIST defined. That result looks like
XPSERVERLIST is not defined. There are some other demo apps in the
Xprint package that are command line. xphellowworld, xpsimplehelloworld,
and xpxthelloworld all need just XPSERVELIST to work.

| How does a client communicate with the server to get the list of
| printers? Is the Xprint server listening to queries on port 6000 (like
| XDMCP)?

Normal X11 network communication. That said, you may need to allow you
other hosts to connect to the Xprt server. Xprt has -ac option that
dissables access controls, or you can use DISPLAY=<xprt server> xhost,
where <xprt server> is like you use for XPSERVERLIST.

Another Xprt option that may help is '-audit 4' which will help you get
more details on what the server is doing.

Most likely, the access controls are the problem, same as with normal
remote X problems.

	-Thomas
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (SunOS)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFADsts+mwggWqA1pQRAsIKAJ917LXWBSHMMcKJC1A9eaOm6h8ZiQCgmB4A
9wBflnh5fbT9Ot0au/Khul8=
=t5DD
-----END PGP SIGNATURE-----


More information about the Xprint mailing list