[Xprint] No printing from Mozilla 1.7.8 nor from Thunderbird

Drew Parsons dparsons at debian.org
Mon Aug 29 22:52:11 EDT 2005


On Mon, 2005-08-29 at 19:35 +0800, Godfrey Harrison wrote:
> What do I need to do to get prints of my e-mails and from printer 
> friendly versions of web-pages &, even, web pages?
> 
> I am running Mozilla & Thunderbird, under Debian 3.1 Sarge, and can't 
> print anything from them.  I can print using Open Office, gedit, and 
> Abiword and Evolution.
>  Mozilla & Thunderbird work fine EXCEPT no printing!
> 
> I can choose from a list of possible printing possibilities
> The lp-64 one connects to my Lexmark E210 printer - its comes to life & 
> its green lights blinks a time or two but nothing else happens. 

Check Xprint is in general working by printing to file (or to pdf). You
could also try printing the file from the command line while you're at
it using lpr (can you normally print postscript files from the command
line?).

I gather you tried both the Xprint printers and the default mozilla
printers.  The Xprint ones have the :64 suffix and the default mozilla
ones have the Postscript/ prefix.

You might try updating the PPD file (it goes in /usr/share/cups/model)
from the vendor or from www.linuxprinting.org. (If you're using LPRng
not CUPS then you could see if CUPS works more smoothly instead).

Try firefox rather than mozilla (probably won't help though, if
thunderbird isn't working either).

There's a slim chance there might be information in /var/log/syslog (or
lpr.log), but I expect not.

Hope that might help.

Drew


More information about the Xprint mailing list